Huxley on Hold

I didn’t want to do it, but I’ve had to give up on my Techzonecom model Huxley printer. I’ve spent another couple of hours on it today and decided it just isn’t worth the hassle. It certainly helped that I found someone on eBay selling printed parts for a Prusa for a decent price.

The Huxley isn’t totally lost, there are many options open to me to get it working, once I have a working printer. Its a chicken and egg problem.

One thing I do have to say, and it seems I’m getting backed up on the forums about this, is never buy anything from TechZone Communications. They seem to have lost the plot and have a long stream of unhappy customers, as well as a below par product. Besides missing parts in the kit I received, and electronics that burst into flame, it also in my opinion is a poorly designed reprap printer. Captive nuts are needed to be melted into the plastic parts, the extruder is external to the main printer with no easy way to mount it and the electronics are just shoddy.

I bought my kit via a UK company called RepRap Central who it turns out are resellers of TechZoneCom kits. I didn’t know this before I bought it, and they don’t make any mention to TechZoneCom. They do however sell other brands of printers, including MakerBot. Communications with RepRap Central are pretty good, and they do have good prices on filament.

So, I’ve got the plastic parts for a Prusa on order, I’ve got plenty of hardware, I’ve got a completed Gen 7 electronics kit built. Hopefully the parts will be arriving next week, and I can have a start at building it. Unfortunately, I’m off to the states for a while for work, so its going to get put on hold for a little while.

Hopefully the Prusa will be a little easier.

Please follow and like us:

5 thoughts on “Huxley on Hold

  1. I bought a techzone too and am having very similar problems. Did the nuts to be pressed into the parts come with your kit? Mine seems to be missing these.

    • I had plenty of the normal nuts that you sink into the parts, but not enough of the nyloc ones. Also had too short a X belt (twice, the replacement one was also too short!) You should be able to get nuts from any hardware store.

  2. I purchased a Mondo from Techzone in Sept 2012. The first board would not connect to any computer. I finally got it replaced and the second motherboard started smoking as soon as I connected the power. It was sent back two months ago and nothing, no responses to my emails, nothing. If you send them money you may get a kit, but getting it to work can be a real problem.

    • At least I know I’m not on my own with the issues. It seems the forum thread on the reprap site has got rather nasty towards them.

      I’m going to get in touch with the UK reseller and advise them to drop the TechZoneCom product line.

      I’ve nearly got my new Prusa MK2 done, so hopefully I’ll be able to print out some better parts for my huxley and maybe get it working.

  3. Pingback: Nearly there! The hotends have arrived! ยป 22BalmoralRoad

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.